Impossible de mettre à jour opensuse du à l'erreur suivante :
linux-rt7j:~ # zypper -n -q refresh
Failed to download /media.1/media from http://download.opensuse.org/distribution/11.3/repo/non-oss/
Abort, retry, ignore? [a/r/i/?] (a): a
Repository 'openSUSE-11.3-Non-Oss' is invalid.
J'ai essayé plein d'options mystiques mais rien n'y fait. Curl/Wget/Ftp fonctionne correctement à travers un proxy.
Au final trouvé sur un forum russe !
export ZYPP_ARIA2C=0
linux-rt7j:~ # zypper in nmap
Retrieving repository 'openSUSE-11.3-Non-Oss' metadata [done]
Building repository 'openSUSE-11.3-Non-Oss' cache [done]
Retrieving repository 'openSUSE-11.3-Oss' metadata [done]
Building repository 'openSUSE-11.3-Oss' cache [done]
Retrieving repository 'openSUSE-11.3-Update' metadata [done]
Building repository 'openSUSE-11.3-Update' cache [done]
Et hop ... Mais bon je cherche des explications à tout cela.
Apparement c'est un client http censé assuré un meilleur service pour les updates.
J'imagine que c'est un problème du à mon proxy et que "ariac" n'utilise pas le setting proxy.
Voir ce lien.
Voir aussi sur ce lien.