Je trouve l'utilitaire multisystem extrêmement utile pour installer des iso sur une clé usb et pouvoir ensuite utiliser cette clé à la place d'un  gravage d'iso aussi temporaires que vite gâché.
Par contre le soft est écrit uniquement pour ubuntu et pas de la plus belle manière, j'ai regardé la portabilité de la chose.
Tout d'abord il faut faire l'install de l'outil en partant des sources à partir de /tmp...
Quelques packages manquent mais sont faciles à trouver (equo install xxxx).
Il faut pas mal de gnome ....
Reste quelques petits trucs :
- Variable SUDO_USER necessaire : faire export SUDO_USER=pierre
- genisofs : En regardant le ebuild du package gentoo cdrkit on voit :
"dosym genisoimage /usr/bin/mkisofs"
Il suffit donc de faire un lien de mkisofs (ln -s mkisofs genisoimage)

- fatresize : Impossible de trouver des sources ou paquets gentoo.
A partir des sources impossible de compiler ...
A la compilation il manque : libparted ...
configure: error: *** libparted >= 1.6.0 not installed - please install first ***
J'ai cette librairie : libparted.so.0 => /usr/lib/libparted.so.0, etonnant de passer de 0 à 1.6 ..
Je tourne dans tous les sens, compare avec une ubuntu :
pierre@ubuntu:/usr/local/share/multisystem$ ldd /usr/sbin/fatresize
linux-gate.so.1 => (0x00d44000)
libparted.so.0 => /lib/libparted.so.0 (0x0025c000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x00c1e000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x00a39000)
libuuid.so.1 => /lib/libuuid.so.1 (0x00f73000)
libdevmapper.so.1.02.1 => /lib/libdevmapper.so.1.02.1 (0x00525000)
libblkid.so.1 => /lib/libblkid.so.1 (0x005b0000)
/lib/ld-linux.so.2 (0x00e68000)
libselinux.so.1 => /lib/libselinux.so.1 (0x00baf000)
On est aussi en libparted.so.0 ...
A court d'idée et de temps je décide de reprendre le binaire kubuntu x64 et ca marche ...
J'ai même mon icône dans le kmenu et tout fonctionne nickel.
Si j'avais le temps je reprendrais bien le code qui est pas très pro ....

Il faut ajouter eval_gettext qui n'est pas trouvé de base.
C'est en fait une fonction disponible dans le package sys-devel/gettext en executant :
. /usr/bin/gettext.sh
Enfin au cas où il râle à cause de la non présence de grub-install, sous sabayon on a grub2-install donc faire un simple lien.
A noter que j'ai aussi essayé sur une opensuse 11.4 au boulot par curiosité et la impossible car gtkdialog n'est plus disponible.